[Mono-list] Web app performance profiling

Andrey Tkach andriy.tkach at stu-electronics.com
Tue Aug 1 05:38:31 EDT 2006

Resending to Mono-list...

> -----Original Message-----
> From: mono-list-bounces at lists.ximian.com [mailto:mono-list-
> bounces at lists.ximian.com] On Behalf Of Gonzalo Paniagua Javier
> Sent: Monday, July 31, 2006 9:33 PM
> To: mono-list at lists.ximian.com
> Subject: Re: [Mono-list] Web app performance profiling
> On Mon, 2006-07-31 at 17:20 +0300, Andrey Tkach wrote:
> > Hello,
> > We have one web application, with some performance issues while
> > testing it on Suse Linux 10.1 and mod_mono 1.1.15. But on .Net, IIS
> > results are much better. I supposed to make a decision whether such
> > platform suitable for our middleware. Are there some web-resources
> > about testing web-applications performance on mono?
> >
> > I feel I need to profile something to see what makes such delays.
> > is the right way to profile mod-mono-server?
> I assume you're letting mod_mono start mod-mono-server. The steps to
> profile it are as follows:
>      1. Start apache.
>      2. Run 'ps aux' and copy the command line used to run
>         mod-mono-server.exe
>      3. Stop apache
>      4. With the same user that runs apache, run the command line
>         in 2 adding the '--profile' parameter to mono.
>      5. Start apache.
>      6. Do a few requests (they will take a lot to process).
>      7. Stop apache
>      8. mod-mono-server will stop and you'll get profile output.
> Note that when --profile is enabled, mono is *extremely* slow. Do as
> many request as you need to get a result that excludes start up stuff.
> -Gonzalo
Thank you Gonzalo,

But I didn't succeed in profiling since I'm not allowed to "do a few
requests" because I'm getting 503-error every time when I run
mod-mono-server separately from apache.
I suspect that could be user-rights issue... Probably I'm missing
something, but how could I run mod-mono-server from the same user as run
apache, if it is system user - apache daemon - wwwrun?
The other thing I've tried to change apache2/uid.conf and rights of
application files and files in /tmp/ dir to start both apache and
mod-mono-server from local user, but also got the same error.
How could I resolve this issue?

Sincerely yours,
Andriy Tkach

More information about the Mono-list mailing list