[Mono-list] xsp / exception rethrown

mtraudt at quantifisolutions.com mtraudt at quantifisolutions.com
Mon May 30 22:42:48 EDT 2005

When I run "xsp" in "/usr/share/doc/xsp/test" I get the
messages below whenever I invoke (or just browse to using
Firefox) any of the test services.


System.NullReferenceException: Object reference not set to
an instance of an object

Server stack trace:

Exception rethrown at [0]:

in (wrapper xdomain-invoke) Mono.WebServer.XSPApplicationHost:ProcessRequest
in (wrapper remoting-invoke-with-check)
in <0x00473> Mono.WebServer.XSPWorker:Run (System.Object state)


The strange thing is, if I run TestService.asmx (for
example) it looks like the method runs and returns a
result.  At least, I can see a result in the test
form.  C# client apps seem to fail, presumably due
to the exception.

I did some investigation and I believe the exception
is being thrown in HttpRuntime.ProcessRequest.

I am using Mandriva LE2005 with Mono 1.1.7 and
the SVN version of xsp.  I get the same error when
using mod_mono, and it seems to occur for any
ASP.NET service.

I assume this is either an installation or a
configuration problem, but I'm not sure where
to start looking.  Any suggestions?

More information about the Mono-list mailing list