[Mono-list] Problem with Windows .NET and Mono.Security

Rob Tanner Rob Tanner <rtanner@linfield.edu>
Thu, 24 Feb 2005 11:10:09 -0800


Thanks.  Well, the first issue I can disregard as a non-issue, but the second
is more problematic. 

The Mono.Security.dll assembly comes out of the download of the installer
mono-1.0.6-gtksharp-1.9.2-win32-0.3.exe off the www.mono-project.com.  I
pulled down a second copy just to make sure nothing got messed up the first
time.  They both produce the same MD5 hash so they should be absolutely
identical (which is what I would have expected).  I unstalled Mono and then
re-installed using the second copy.  I still get the same "Strong name
validation failed for assembly 'Mono.Security'" error.  Do you think this is
something I need to report as a bug?


--On Thursday, February 24, 2005 01:30:52 PM +1300 Ralph Mason
<ralph.mason@telogis.com> wrote:

> You don't 'register' a .net assembly (this is a com thing).   You can put
> it in the gac if you like.
> The second one sounds like a modified assembly after it was signed.
> Ralph
>> I downloaded the Novell LDAP libraries for C# which use Mono.Security, so I
>> downloaded Mon and installed it.  First I tried to register
>> Mono.Security.dll and I got this error: "Mono.Security.dll was loadedbut
>> the DllRegisterServer entry point was not found.  The file cannot be
>> registered."
>> I went ahead and built and tried to run a piece of sample code from the
>> LDAP library and I get this error:  "Error: Strong name validation failed
>> for assembly 'Mono.Security'."
>> I presume the two problems are related, but I have no idea what's going on.
>> Anybody have a clue?
>> Thanks,
>> Rob
>> Life can be interesting when a UNIX guy suddenly starts coding C# on
>> Windows 2003.  :-)

Rob Tanner
UNIX Services Manager
Linfield College, McMinnville OR