[Mono-list] problem running monodevelop 1.1.10

Fredrik Elestedt fredrik at elestedt.com
Thu Dec 8 02:24:59 EST 2005

matt.raffel at mindspring.com wrote:
> So I downloaded the mono 1.1.10 installer, ran it.  I tried this both as root and as myself.    It seems to install ok.  Go through the screens, no error messages during the install.   
> If double click the MonoDevelop.desktop it never starts.   or if I run monodevelop from the commandline in the bin dir I get the following error:
> System.TypeInitializationException: An exception was thrown by the type initializer for Gnome.ModuleInfo ---> System.DllNotFoundException: gnomesharpglue-2
> in (wrapper managed-to-native) Gnome.ModuleInfo:gnomesharp_gnome_moduleinfo_get_name_offset ()
> in <0x00008> Gnome.ModuleInfo:.cctor ()--- End of inner exception stack trace ---
> in <0x00000> <unknown method>
> in <0x00025> Gnome.Modules:get_UI ()
> in <0x00440> MonoDevelop.Ide.Gui.IdeStartup:Run (System.String[] args)
> in <0x00169> MonoDevelop.Core.AddIns.AddInService:StartApplication (System.String addinId, System.String[] parameters)
> So it looks like some configuration information isnt setup.   But I dont know what.   Can someone help me get configured?
> Im running Mandriva and KDE if that makes a diff...
> Thnx
> Matt
> _______________________________________________
> Mono-list maillist  -  Mono-list at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-list

You need to recompile Monodevelop.

// Fredrik

More information about the Mono-list mailing list