[Mono-list] NAnt config file framework problem with mono 0.91.99

Gert Driesen gert.driesen@pandora.be
Wed, 12 May 2004 20:36:38 +0200

----- Original Message ----- 
From: "GUnit" <gmiyake@carter-inc.com>
To: <mono-list@lists.ximian.com>
Sent: Wednesday, May 12, 2004 7:25 PM
Subject: [Mono-list] NAnt config file framework problem with mono 0.91.99

> The latest CVS version fixed the problem with the NAnt config file
> encoding. Thx.
> I am now getting the following error when trying to build with NAnt:
> "The current runtime framework 'mono-1.0' is not correctly configured in
> the NAnt configuration file."
> This configuration file worked under mono 0.31 and I have not modified
> my NAnt version.  I tried updating
> NAnt and the nant build failed with a similar error. The NAnt config
> file and error message follow.

Recently, some changes to the packaging /directory structure of Mono were
made that will no longer allow the old configuration section to work.

NAnt cvs will now determine the location of mono using pkg-config (will this
only work when dev packages are installed ?), so you should no longer have
to manually modify the NAnt configuration file.

However, we (well, at least I am) will wait until the packaging / directory
structure of Mono has finalized before making more changes to NAnt, so you
might still have problems for now ...  We might even be facing more probems
soon, but I guess Ian (also a member of the NAnt team) is going to be
tackling those ...

If you rebuild NAnt from cvs, you should at least get a more meaningful
error message, and the mono prefix should be pixed up automatically :

$ export CVSROOT=:pserver:anonymous@cvs.sourceforge.net:/cvsroot/nant
$ cvs -z3 co nant
$ cd nant
$ make