[Mono-list] Need help configuring mod_mono with Beta 3

Patrick McNamara patrick_j_mcnamara@hotmail.com
Sun, 20 Jun 2004 16:08:59 -0400

I think I'm doing something wrong in my httpd.conf file, but I've tried 
everything I can find on google.
(mod_mono and xsp both from CVS)
here's my httpd.conf:
LoadModule mono_module /usr/lib/apache2/modules/libmod_mono.so
MonoUnixSocket /tmp/mod_mono_server
MonoExecutablePath /usr/bin/mono

Alias /mono "/usr/share/doc/xsp/test"
MonoApplications "/mono:/usr/share/doc/xsp/test"

<Directory /usr/share/doc/xsp/test>
    SetHandler mono
    #AddHandler mono .aspx .ascx .asax .ashx .asmx .cs .config

I made sure that mod-mono-server.exe is running and I chowned 
/tmp/mod_mono_server to the apache2 user and group.  When I attempt to 
connect to localhost/mono/index.aspx I can see the processor work and memory 
is consumed, but the browser just sits there waiting for a reply.  As I 
issue more requests for index.aspx, more and more memory is consumed, but a 
page is never returned.  Eventually after about 5 requests the 
mod-mono-server reports:
Warning: Repeated allocation of very large block (appr. size 100667392):
        May lead to memory leak and poor performance.
When I kill mod-mono-server.exe all of the memory is released.
I also tried changing my httpd.conf to read <Directory /mono> but that just 
returned the source code for index.aspx.

Any help is appreciated.

MSN Movies - Trailers, showtimes, DVD's, and the latest news from Hollywood!