[Mono-list] XSP 0.11 problem

Gonzalo Paniagua Javier gonzalo@ximian.com
Fri, 23 Apr 2004 01:10:53 +0200

El jue, 22-04-2004 a las 20:24, Andrew Arnott escribió: 
> Thank you.  I used ./configure --prefix=/usr, and the mod_mono and XSP
> installed in the /usr/bin folder now instead of /usr/local/bin, as I
> wanted.  However, Apache2's errorlog still indicated that Apache 2 was
> looking in the /usr/local/bin folder for both "mono" and
> "mod-mono-server".  Do I have old files that need to be removed
> somewhere?  A workaround was to create to symbolic links, one for each
> file that was sought.

That's because mod_mono was compiled/installed in with
--prefix=/usr/local and the default path to look for mono will be

If that's what you want, it's ok, you can use the directives available
(MonoExecutablePath, MonoPath, MonoServerPath) to tell the module where
to find mono and mod-mono-server.exe, but I guess it's easier to just
recompile/reinstall mod_mono using --prefix=/usr too.

> Second, the MonoApplications directive in Apache's configuration file
> works fine.  But I want my root web site to be a Mono web app.  I
> tried "MonoRoot", and that didn't work.  I also tried using
> MonoApplications "/:/home/Andrew/localweb/" and that failed also.  Any
> ideas?

You have to set Apache ServerRoot to /home/Andrew/localweb and then do
add <Directory /home/Andrew/localweb> or <Location /> (this only works
for apache 2).