[Mono-list] XSP 0.11 problem

Andrew Arnott AndrewArnott@byu.edu
Thu, 22 Apr 2004 12:24:17 -0600

Thank you.  I used ./configure --prefix=3D/usr, and the mod_mono and XSP =
installed in the /usr/bin folder now instead of /usr/local/bin, as I =
wanted.  However, Apache2's errorlog still indicated that Apache 2 was =
looking in the /usr/local/bin folder for both "mono" and =
"mod-mono-server".  Do I have old files that need to be removed =
somewhere?  A workaround was to create to symbolic links, one for each =
file that was sought.

Second, the MonoApplications directive in Apache's configuration file =
works fine.  But I want my root web site to be a Mono web app.  I tried =
"MonoRoot", and that didn't work.  I also tried using MonoApplications =
"/:/home/Andrew/localweb/" and that failed also.  Any ideas?

Thanks for your help.

-----Original Message-----
From: mono-list-admin@lists.ximian.com =
[mailto:mono-list-admin@lists.ximian.com] On Behalf Of Gonzalo Paniagua =
Sent: Wednesday, April 21, 2004 10:51 AM
To: mono-list@lists.ximian.com
Subject: Re: [Mono-list] XSP 0.11 problem

El mi=E9, 21-04-2004 a las 18:37, Andrew Arnott escribi=F3:
> I had a root directory and the /mono virtual directory set up
> previously, but since upgrading to mod_mono 0.8 and XSP 0.11, I have
> noticed several issues:
> 1. The mod-mono-server.exe is compiled to /usr/local/bin rather than
> /usr/bin.  According to the web page I downloaded it from, /usr/bin
> should have been its location.

Use ./configure --prefix=3D/usr

> 2. Apache 2.0.49 failed to start mod-mono-server.exe automatically.
> Maybe due to its non-standard location?  But I moved =
> to /usr/bin and it still did not get loaded by Apache automatically.

If mono and xsp are installed in prefix=3D/usr, it should work. If it
fails, look at the apache error_log file.

> 3. By starting mod-mono-server.exe manually on the command line, I've
> managed to get /mono to work (the standard xsp/test directory), but my
> root web which is an ASPX set does not load up.  Instead, I get the
> "Service Temporarily Unavailable" error, which seems standard for when
> the mod-mono-server.exe is not loaded.

That's a problem with file permissions that should go away if the module
successfully runs mod-mono-server.

> 4. No apache configuration files appears to have been automatically
> modified, as the web page said they would be.

If make install run successfully and you didn't have LoadModule for
mod_mono, that line is added. If it's already there, nothing happens.


Mono-list maillist  -  Mono-list@lists.ximian.com