[Mono-list] Mono on NetBSD and problems compiling corlib

Alan Knowles alan@akbkhome.com
Sat, 04 Jan 2003 09:56:28 +0800


>[1]   Trace/BPT trap (core dumped) MONO_PATH= mono ...
>gmake: *** [../../class/lib/corlib.dll] Error 133
>I've tried upping the ulimits to the maximum etc, and using mint instead of mono.  Still the same error occurs.  FYI at the time it occurs about 150mbs of memory are being used.
worth a thought, have you got any other process limits on the machine, 
eg. running process time, max cpu time.... - I've seen these before on 
BSD boxes.. where that Admin didnt even realize that they where there, 
and we spent days trying to persuade him to check that page in the manual :)

>I'd like to work around this, or better still fix the problem!  Has anyone come across this before on another OS?  Any ideas on how to attack this?  Is it posible to split the build processes into smaller chunks and stick them back together again, aka cc -c style?
I would guess that the only way to do that would be to serialize the 
method block trees and write the to temporary files, then load them as 
neccessary.... - eg. at resolve/optimize/output time....