[Mono-list] Lame newbie question about debugger/autogen.sh

Darren Tuer darren_tuer@technologyonecorp.com
Thu, 27 Feb 2003 21:24:15 +1000

I'm sure that the answer to this problem is very simple, I just haven't
worked it out ...

I am trying to build the mono debugger from a CVS checkout from two days

There is no configure file, nor a make file, just the autogen.sh script.

I've seen pleny of posts asking about how to build from CVS, and they all
say to run ./autogen.sh

I've tried running ./autogen.sh, but all I get is

[user1@client debugger]# ./autogen.sh
: bad interpreter: No such file or directory
[user1@client debugger]#

This is just a shell script, is it not ?  Why am I able to run other shell
scripts, but not this one ?

The system is a reasonably straight out of the box install of RedHat8,
nothing fancy.

I confess that I am not any great Linux user, mostly I use Windows, but want
to give the mono project a try and are somewhat lost.  Everything else I've
managed to stumble my way through but come to a halt with getting the
debugger built.

I am also having the same problem building gal and gtkhtml from CVS with the
exact same problem, so cannot get the monodoc project built either.

Can someone give me some idiot proff instructions on where I have gone wrong
? ;-)