[Mono-list] Mono from CVS, segmentation fault

Sam Clegg sam@superduper.net
Mon, 18 Aug 2003 11:10:57 +0100

Content-Type: text/plain; charset=iso-8859-1
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On Fri, Aug 15, 2003 at 04:37:40AM +0200, =D8yvind Hvamstad wrote:
> Hi, happy to hear about the 0.26 release.
> Since no packages are released from debian and I really would like the
> ThreadPool fixes, I tried to make a checkout from cvs. I'm unable to
> make it build though.
> I ran the mono-build.sh script and it completes successfully. Then I try
> 'make fullbuild', but it turns out with a segmentation fault:
> make[1]: Entering directory `/usr/local/src/mcs/mcs'
> mcs    -g /target:exe /out:mcs.exe AssemblyInfo.cs anonymous.cs
> assign.cs attribute.cs driver.cs cs-tokenizer.cs cfold.cs class.cs
> codegen.cs const.cs constant.cs convert.cs decl.cs delegate.cs enum.cs
> ecore.cs expression.cs flowanalysis.cs genericparser.cs interface.cs
> iterators.cs literal.cs location.cs modifiers.cs namespace.cs
> parameter.cs pending.cs report.cs rootcontext.cs statement.cs support.cs
> typemanager.cs symbolwriter.cs tree.cs cs-parser.cs
> /usr/local/src/install/bin/mcs: line 2:  6800 Segmentation fault    =20
> /usr/local/src//install/bin/mono /usr/local/src//install/bin/mcs.exe
> "$@"

I had the same problem once.  Have you tried running the above
command with the un-installed mono
(/usr/local/src/mono/mono/mini/mono).  This worked for me IIRC.

It has something to do with differnce between the libmono.so that
libtool creates during "make" and the one it installs during
"make install".  I never found time to track this down though.
sam clegg
:: sam@superduper.net :: http://superduper.net/ :: PGP : D91EE369=20
$superduper: .signature,v 1.13 2003/06/17 10:29:24 sam Exp $

Content-Type: application/pgp-signature
Content-Disposition: inline

Version: GnuPG v1.2.2 (GNU/Linux)