[Mono-list] Mono from CVS, segmentation fault

Řyvind Hvamstad oyvind@hvamstad.net
Fri, 15 Aug 2003 04:37:40 +0200


Hi, happy to hear about the 0.26 release.

Since no packages are released from debian and I really would like the
ThreadPool fixes, I tried to make a checkout from cvs. I'm unable to
make it build though.

I ran the mono-build.sh script and it completes successfully. Then I try
'make fullbuild', but it turns out with a segmentation fault:

make[1]: Entering directory `/usr/local/src/mcs/mcs'
mcs    -g /target:exe /out:mcs.exe AssemblyInfo.cs anonymous.cs
assign.cs attribute.cs driver.cs cs-tokenizer.cs cfold.cs class.cs
codegen.cs const.cs constant.cs convert.cs decl.cs delegate.cs enum.cs
ecore.cs expression.cs flowanalysis.cs genericparser.cs interface.cs
iterators.cs literal.cs location.cs modifiers.cs namespace.cs
parameter.cs pending.cs report.cs rootcontext.cs statement.cs support.cs
typemanager.cs symbolwriter.cs tree.cs cs-parser.cs
/usr/local/src/install/bin/mcs: line 2:  6800 Segmentation fault     
/usr/local/src//install/bin/mono /usr/local/src//install/bin/mcs.exe
"$@"

Can anyone help me? I have been looking for similar behaviour on the
list but couldn't find any. I have successfully built from cvs before
(some time ago though).

Can I use mcs from 0.24 with a different set of dll's? Are the
monocharge still in use? I have tried several combinations, but are
unable to make them work.

Thanks in advance.