[Mono-list] Compiling under windows

Didier Clabaut clabaut_didier@hotmail.com
Wed, 30 Apr 2003 12:41:20 +0200

Hi all,

Using WinCVS I downloaded all the source code, and I'm trying to compile
them, without success. For instance, I'd like to do some work on the
System.XML namespace. In the folder I find a .Net solution file, but it
doesn't compile at all, files are missing, others have been altered
(class Parser is renamed to yyParser, ...). The Nant utility that came
with the CVS "won't run in DOS mode", even though I thought it was a
command line tool. I tried to re-compile that one but with no success. I
downloaded the latest "stable" version of Nant with binary, and that one
doesn't complain, but falls in a loop (I let it run overnight and it was
still displaying the same text). So it's also useless...
On Linux (Mandrake 9.1) itself I'm experiencing the same kind of
problems when I try to build.

I use SharpDevelop and WinCVS, I compile manually (#Develop only
compiles once, then just says "succesfull" the next times).
I tried compiling my own classes and didn't get any problems with it, so
it's not a compiler or programmer bug :-).

I'm a .NET/Java developer at IBM, and would like to start demonstrating
Mono to our clients. I'm using the Duwamish site as a starting point and
would like to be able to do a mono-demo in about a month (right now it
crashes on global.asax :-(). I will commit my time to contribute, but if
I'm not even able to compile a simple dll I'm not going to get very far.

Hoping to get an answer on this,

Didier Clabaut