[Mono-list] CVS problem with line ends

spouliot@motus.com spouliot@motus.com
Wed, 9 Oct 2002 07:58:06 -0400

Yesterday I tried to make a patch to ICryptoTransform (because it should
inherit IDisposable). However I saw that the patch was trying to replace
the whole file (instead of just one line).

What I found out is that some files, like ICryptoTransform.cs, have line
ends defined as 0x0D, 0x0D, 0x0A but others, like Changelog, have a normal
0x0D, 0x0A line ends.

I'm tried both WinCVS and TortoiseCVS with the same results. Both software
are supposed to transfer line ends between UNIX and DOS without any problem
(and indeed many files are correct). I'm new with CVS so i'm not sure if
this is about configuration (that's why I used 2 different software) or the
repository. Has anybody seen this before ?

Can someone try to checkout ICryptoTransform.cs (in
\mcs\class\corlib\System.Security.Cryptography) on Windows and tell me if
the file is normal (or like mine)?

Sébastien Pouliot
Architecte Sécurité / Security Architect
Motus Technologies
tel: 418 521 2100 ext 307
fax: 418 521 2101
courriel / email: spouliot@motus.com