[Mono-list] RE: Compiliation on Linux box problem...

Daniel Morgan danmorg@sc.rr.com
Mon, 27 May 2002 18:00:01 -0400


Hi Francisco,

I thought others maybe interested with your progress.  

Here is a link to the Mono Mailing Lists.  It will allow you to read the
archives and it will allow to subscribe/unsubscribe to the various
mailing lists.
http://www.go-mono.com/mailing-lists.html
 
If you think there is a bug with mono/mcs, go to
http://bugzilla.ximian.com/ and enter a new bug.

I'm only guessing about your compile errors: Line 97 sounds like the
Item indexer (this[]) maybe missing some brackets, and Line 101 sounds
like you are trying to set a constant.

Do you think you can update the sourceforge site with your latest Npgsql
changes?

Daniel 

-----Original Message-----
From: Francisco Jr. [mailto:fxjrlists@yahoo.com.br] 
Sent: Monday, May 27, 2002 5:30 PM
To: Daniel Morgan
Subject: RE: Compiliation on Linux box problem...

 --- Daniel Morgan <danmorg@sc.rr.com> escreveu: 
> I'm glad to hear you can build Mono now.  Can you
> run it?
> 

Yes! In fact, I tried to compile from rpm source with
no luck. But the precompiled rpm is perfect!

> How about your Npgsql provider?  Can it run on Mono
> and successfully
> connect to a PostgreSQL database?
> 

Well, in the first try I received the following error:

mcs -r /usr/lib/System.Data.dll --target library -o
Npgsql.dll
NpgsqlCommand.cs NpgsqlConnection.cs
NpgsqlException.cs
NpgsqlParameter.cs NpgsqlParameterCollection.cs
AssemblyInfo.cs
NpgsqlParameterCollection.cs(97) error CS0654: Method
`System.Collections.ArrayList.get_Item()' is
referenced without
parentheses
NpgsqlParameterCollection.cs(101) error CS0131: Left
hand of an
assignment must be a variable, a property or an
indexer
Error: Compilation failed
RESULT: 1

Also, as you can see I had to put -r
/usr/local/System.Data.dll but -r System.Data.dll
didn't work. But it is ok. The System.Data.dll is in
/usr/lib and I tried to put /usr/lib in LD_EXPORT_PATH
with no luck :(

After replacing the line with a fake one, I could
compile Npgsql!!!

Well, so I compiled a client application.

When I run, I got the following error:

WARNING **: unhandled exception
System.ArgumentException: "An invalid argument was
specified "
in <0x00070>
System.Net.Sockets.NetworkStream:Read(byte[], uint,
uint)
in <0x001a2>
Npgsql.NpgsqlConnection:HandleStartupPacketResponse()
in <0x002c3> Npgsql.NpgsqlConnection:Open()
in <0x0003d> .Test:Main (string[])


But with Ethereal I could see that some bytes are sent
on the wire!! That's a good thing! The problem is when
I try to read from the networkstream. 

After some trial and error, I could see that the
Networstream.ReceiveBufferSize was returning 87380 and
it was throwing the exception. I changed the value
and... it worked!! At least the connection. :) I will
try the other tests.

So I think that just the first compilation errors
about the get_Item() and set property are the real
one. I will try to figure out why it is happening.

Thanks Daniel!


Francisco Jr.


_______________________________________________________________________
Yahoo! Encontros
O lugar certo para vocÍ encontrar aquela pessoa que falta na sua vida.
Cadastre-se hoje mesmo!
http://br.encontros.yahoo.com/