[Mono-list] GTK# Help

Jamin Philip Gray jamin@pubcrawler.org
Mon, 23 Dec 2002 11:19:22 -0600 (CST)

On Mon, 23 Dec 2002, Amerigo5 Amerigo5 wrote:

> Hi,
> I installed mono-0.17 and gtk-sharp-0.6 in Red Hat 8.0 and everything went 
> well. Then , I tried the first sample from Gnome.Net tutorial (website) or 
> even the sample that came with gtk-sharp source. I was able to successfully 
> compile the .cs file but when I run it (mono test.exe), I am getting the 
> error: "Failed to Load Library libgtksharpglue.so (gtksharpglue): 
> libgtksharpglue.so: cannot open shared object file: No such file or 
> directory"
> Also, I cannot find the libgtksharpglue.so anywhere in my machine (using 
> locate libgtksharpglue).

Is your locate database updated?  libgtksharpglue.so should be in the lib/
directory of the prefix you installed in (/usr/local by default I think).
Try setting the environment variables LD_LIBRARY_PATH and MONO_PATH to
inlude PREFIX/lib.  So if you installed gtk-sharp in /usr/local, make sure
those environment variables include /usr/local/lib.  

Hope that helps,

name:   Jamin Philip Gray
email:  jamin@pubcrawler.org
icq:    1361499
aim:    jamingray47
yahoo:  jamin47
web:    http://pubcrawler.org

A professor is someone who talks in someone else's sleep.