[Mono-dev] Q: "The assembly mscorlib.dll was not found"

Ran Shalit ranshalit at gmail.com
Thu Sep 22 10:06:17 UTC 2016


I am trying to get mono with armv5. I've made some progress on this
issue as following.

I am using 2009q3 for arm , with version 4.0.0

I've configured it as following with autogen.sh:
CXX=arm-none-linux-gnueabi-g++ CC=arm-none-linux-gnueabi-gcc
CFLAGS="-march=armv5te -mtune=arm926ej-s -mfloat-abi=soft"
./autogen.sh --host=arm-none-linux-gnueabi --disable-mcs-build

On build I got only one error :
In file included from sgen-major-copy-object.h:33,
                 from sgen-marksweep.c:857:
sgen-copy-object.h: In function 'copy_object_no_checks':
sgen-copy-object.h:41: sorry, unimplemented: inlining failed in call
to 'par_copy_object_no_checks': function body not available
sgen-copy-object.h:95: sorry, unimplemented: called from here

>>> I had removed "MONO_ALWAYS_INLINE" for the function decleration - Is that OK ?

Yet, I still get the same error on exectuable.
# ./mono /home/modem/Elbit/Elbit_test/Elbit.Jdss.TestConsoleMonoNoUI.exe
The assembly mscorlib.dll was not found or could not be loaded.
It should have been installed in the
`/usr/local/lib/mono/4.5/mscorlib.dll' directory.

After "make" , and "make install" , I deployed it as following:
I copied all /usr folder into some folder in target (I don't have
access to /usr/local/ which is read-only filesystem, but to
/home/usr/local .... )

Thank you for any suggestion,

More information about the Mono-devel-list mailing list