[Mono-dev] Still stuck in a bad place with TLS 1.2 support

Miguel de Icaza miguel at microsoft.com
Thu Nov 3 02:42:16 UTC 2016

Hello Guerry,

This is how you can test whether you have Mono properly configured and installed to use TLS 1.2:

MONO_TLS_PROVIDER=btls csharp -e 'new System.Net.WebClient ().DownloadString ("https://www.howsmyssl.com/")' | grep  "TLS 1.2"

If the result looks like this:

          TLS 1.2, the most modern version of the encryption

You have TLS 1.2 working. 


On 11/1/16, 5:58 PM, "Mono-devel-list on behalf of gsemones" <mono-devel-list-bounces at lists.dot.net on behalf of guerry at traxia.com> wrote:

    I've posted before about this, but I've been away trying new approaches
    which also did not work. I'm back to see if my new approaches have any
    answers. My project is at a complete stand still and has been for several
    I have a OS X console app that is hosting Owin as a web service and SignalR.
    I need TLS 1.2 to work serving a certificate bound to a port on the Mac, as
    well as for HTTP clients used in the service. The Mono Legacy TLS 1.0
    Provider does not work, particularly with our certificate, which is
    currently generated by LetsEncrypt, and which I believe is only authentic
    for TLS 1.1 and 1.2. I guess I should try a certificate with TLS 1.0
    Miguel and others have been very helpful, but no combination of things I've
    tried up through last month worked. Then came the announcement that Boring
    TLS was available in the latest Mono bits, and so I shifted gears. 
    I built Mono and could see lots of references to Boring TLS. I built my Mono
    project (not Xamarin.Mac) using the latest Mono and targeting .NET Framework
    4.6, and ran it using the same. No matter what I did, I could only get the
    Legacy TLS provider, or if I specified "btls" it would fail with an
    exception because Boring SSL was not found. I could not find any docs about
    whether I need to build/install Boring separately or if the bundled copy in
    Mono was supposed to get built. Is the Mono Boring TLS stuff only for
    I next read again about Apple TLS and Xamarin.Mac. I made a new Xamarin.Mac
    project and ported my code to it. I found that Owin and other packages were
    not available on Nuget for Xamarin.Mac Mobile Framework" but I had success
    with Xamarin.Mac .NET 4.5 Framework. However, the Apple TLS Provider does
    not appear available and will not load. I only get the Legacy Provider. Does
    the Apple TLS Provider only work with Xamarin.Mac Mobile Framework?
    I feel like I'm in a twisty maze of passages all alike.
    Is there a document somewhere that points up which TLS options are available
    for which frameworks?
    Much thanks in advance,
    View this message in context: https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fmono.1490590.n4.nabble.com%2FStill-stuck-in-a-bad-place-with-TLS-1-2-support-tp4669106.html&data=02%7C01%7Cmiguel%40microsoft.com%7Ca5de0a6e8fbf4e990eb508d402a37f0d%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636136348624537474&sdata=mULplb1Cxph24f%2B6wjPJog611gmsgN3vv7T1ppxbCqE%3D&reserved=0
    Sent from the Mono - Dev mailing list archive at Nabble.com.
    Mono-devel-list mailing list
    Mono-devel-list at lists.dot.net

More information about the Mono-devel-list mailing list