[Mono-dev] mono 4.0.0 xbuild won't build project

Alexander Köplinger alex.koeplinger at outlook.com
Tue Jun 2 22:04:07 UTC 2015

No idea about the xbuild issue, but you should be able to build Pash on another machine and just copy over the .exe, it is managed code after all ;) 
From: chaselton at gmail.com
Date: Tue, 2 Jun 2015 16:54:19 -0500
To: mono-devel-list at lists.ximian.com
Subject: [Mono-dev] mono 4.0.0 xbuild won't build project

Just built and installed mono 4.0 from sources.  Basic "Hello World" console program builds and runs successfully but basic "Hello World" project (hello.proj) won't build; xbuild displays the banner and then exits with no errors and without building the project.

Here's the hello.proj

< Project xmlns="http://schemas.microsoft.com/developer/msbuild/2003">;

	<Target Name="Build">

		<Message Importance="High" Text="Hello, World!" />



I;ve tried /verbosity:detailed and several other flags.  I've tried running path/to/mono -v /path/to/xbuild.exe proj.proj. Same thing happens every time:

/bld/pash/Pash-Project-Pash-bc07215 $ xbuild Pash.proj

XBuild Engine Version 12.0

Mono, Version

Copyright (C) 2005-2013 Various Mono authors

/bld/pash/Pash-Project-Pash-bc07215 $

Please help...this is driving me crazy.


Sent from my Android device with K-9 Mail. Please excuse my brevity.
Mono-devel-list mailing list
Mono-devel-list at lists.ximian.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ximian.com/pipermail/mono-devel-list/attachments/20150603/144b5230/attachment.html>

More information about the Mono-devel-list mailing list