[Mono-dev] mono 4.0.0 xbuild won't build project

Cyd Haselton chaselton at gmail.com
Tue Jun 2 21:54:19 UTC 2015

Just built and installed mono 4.0 from sources.  Basic "Hello World" console program builds and runs successfully but basic "Hello World" project (hello.proj) won't build; xbuild displays the banner and then exits with no errors and without building the project.

Here's the hello.proj
< Project xmlns="http://schemas.microsoft.com/developer/msbuild/2003">
	<Target Name="Build">
		<Message Importance="High" Text="Hello, World!" />

I;ve tried /verbosity:detailed and several other flags.  I've tried running path/to/mono -v /path/to/xbuild.exe proj.proj. Same thing happens every time:

/bld/pash/Pash-Project-Pash-bc07215 $ xbuild Pash.proj
XBuild Engine Version 12.0
Mono, Version
Copyright (C) 2005-2013 Various Mono authors
/bld/pash/Pash-Project-Pash-bc07215 $

Please help...this is driving me crazy.

Sent from my Android device with K-9 Mail. Please excuse my brevity.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ximian.com/pipermail/mono-devel-list/attachments/20150602/9069a633/attachment.html>

More information about the Mono-devel-list mailing list