[Mono-dev] Assertion not met when embedding mono

Marcelo Zabani mzabani at gmail.com
Fri May 24 16:48:45 UTC 2013

I'm trying to run a program that embeds mono and am receiving the following

*TYPE: 32*
** Assertion at mini-amd64.c:487, condition `amd64_is_imm32 (disp)' not met*
*  at <unknown> <0xffffffff>*
*  at System.Console..cctor () <0x0001b>*
*  at (wrapper runtime-invoke) object.runtime_invoke_void
(object,intptr,intptr,intptr) <0xffffffff>*
*  at <unknown> <0xffffffff>*
*  at NamServer.RequestPipeline.Init () <0x0000b>*
*  at (wrapper runtime-invoke) object.runtime_invoke_void
(object,intptr,intptr,intptr) <0xffffffff>*

I tried running a regular .NET console program and it ran fine, so I have
no idea what this can be. I tried this with mono 3.0.10 and mono straight
from the github repository as of some time last night.
Also, this is not my "regular" mono installation. This is installed in a
separate directory, and thus I override some environment variables before

>From the native stacktrace (which is rather large, so if you need it tell
me and I'll share it with you) I can confirm that the correct version of
libmono-2.0.so is being loaded (the one from my custom install).
What could I be doing wrong?
Thanks in advance.

Marcelo Zabani
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ximian.com/pipermail/mono-devel-list/attachments/20130524/995843ae/attachment.html>

More information about the Mono-devel-list mailing list