[Mono-dev] Reference to System.Data.Entity in monodevelop trunk

Michael Hutchinson m.j.hutchinson at gmail.com
Tue Sep 25 17:32:07 UTC 2012

On 15 September 2012 13:07, Steven Boswell II <ulatekh at yahoo.com> wrote:
> After building and installing a Fedora Core 17 RPM for the trunk version of
> mono, I tried to do the same for the trunk version of monodevelop.  When I
> tried to install the new monodevelop RPM, it reported a failed dependency of
> "mono(System.Data.Entity) =".  Latest mono doesn't have a
> System.Data.Entity in its .NET 4.0 assemblies.
> The enclosed patch shows my attempt to remove all references to
> System.Data.Entity, but it didn't work.  For now, I forced the install by
> adding "--nodeps" to my RPM install command line.  So far, monodevelop is
> running, but I haven't beaten it up very much yet.
> Just an FYI for the monodevelop maintainers, and cc'd to the mono-devel list
> in case System.Data.Entity was supposed to be there.

That's a bug in the Fedora packages, you should report it to the
Fedora packagers. MD does not depend on System.Data.Entity.

The patch is incorrect, that's simply MD's definition of what is
expected to be in certain target frameworks but does not affect its
actual dependencies at all.

Michael Hutchinson

More information about the Mono-devel-list mailing list