[Mono-dev] Reference to System.Data.Entity in monodevelop trunk

Steven Boswell II ulatekh at yahoo.com
Sat Sep 15 17:07:22 UTC 2012

After building and installing a Fedora Core 17 RPM for the trunk version of mono, I tried to do the same for the trunk version of monodevelop.  When I tried to install the new monodevelop RPM, it reported a failed dependency of "mono(System.Data.Entity) =".  Latest mono doesn't have a System.Data.Entity in its .NET 4.0 assemblies.

The enclosed patch shows my attempt to remove all references to System.Data.Entity, but it didn't work.  For now, I forced the install by adding "--nodeps" to my RPM install command line.  So far, monodevelop is running, but I haven't beaten it up very much yet.

Just an FYI for the monodevelop maintainers, and cc'd to the mono-devel list in case System.Data.Entity was supposed to be there.

Steven Boswell
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ximian.com/pipermail/mono-devel-list/attachments/20120915/e88930a8/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: monodevelop-
Type: application/octet-stream
Size: 2242 bytes
Desc: not available
URL: <http://lists.ximian.com/pipermail/mono-devel-list/attachments/20120915/e88930a8/attachment.obj>

More information about the Mono-devel-list mailing list