[Mono-dev] Was giving up, now have hope.

Rob Wilkens robwilkens at gmail.com
Tue May 1 13:20:22 UTC 2012

I think i can work around this..  Though I want to document this here 
because i think something went wrong...

I searched the mono (_not_ the gtk-sharp) source and found this:

./eglib/src/glib.h:#define g_thread_supported()   TRUE

But oddly enough i could _not_ find glib.h in the installed mono 
directory....  This is not to say it should be..  but something was 
looking for that macro in gtk-sharp.

I get the distinct impression that i can just redefine 
g_thread_supported() in the local copy of gtk-sharp source to 'true' and 
it will work after i rebuild it.

If it doesn't and if i can't figure out another work-around, I'll be 
back here later.

If you don't hear from me, presume it worked.


On 05/01/2012 08:45 AM, Rob Wilkens wrote:
> Ok, I've managed to get rid of most of my errors via using the
> parallel build environment configuration...
> But I've got one more error preventing me from proceeding with what i
> wanted to work on, and i think it's related to gtk-sharp, in which
> case i'm either asking on the wrong mailing list (probably) or maybe i
> should find another version of gtk-sharp(?) to try to build.
> Here's the problem copied/pasted directly from command line of both programs:
> mono: symbol lookup error:
> /home/robwilkens/mono/lib/libglibsharpglue-2.so: undefined symbol:
> g_thread_supported
> Oddly enough, i tried googling the error message (copy/paste) from
> libglibsharpglue to the end of the line, and nothing came up..  I
> guess i'm the first one to run across this particular problem, or at
> least the first to ask publicly.
> I get the same error from both programs that i was trying to test
> before (namely: monodevelop and GhettoGtkAdmin)...
> Is this mono or should i look for a gtk-sharp mailing list and ask there?
> Thanks,
> Rob

More information about the Mono-devel-list mailing list