[Mono-dev] --------Monodevelop , MySql Connection problem ...Pls Help--------

Daniel Morgan monodanmorg at yahoo.com
Mon Sep 12 09:06:31 EDT 2011

The GAC is only used at runtime.  The C# compiler does not use the GAC for assemblies you reference.   The C# compiler needs to find the MySql.Data.dll file that is not in the GAC.  You may need to add to the PATH environment variable where you put the MySql.Data.dll file.

From: lrt_sat <satish.anasane at gmail.com>
To: mono-devel-list at lists.ximian.com
Sent: Saturday, September 10, 2011 8:33 AM
Subject: [Mono-dev] --------Monodevelop , MySql Connection problem ...Pls Help--------

I am quite new to Mono and MySql , pls ignore if I sounds something silly.

I am trying to connect to MySql , just following this thread
and had following problems

>>> While installing Installing MySql.Data.dll in the GAC by executing

gacutil -i MySql.Data.dll ,

i got the message

"Failure adding assembly MySql.Data.dll to the cache: gac directories could
not be created, possibly permission issues."

Then i tried :

sudo gacutil -i MySql.Data.dll

and got the message

"Installed MySql.Data.dll into the gac (/usr/lib/mono/gac)" ,

It was looking fine , so I continued and..

>>> tried to execute the program as mentioned in the thread,

mcs TestExample.cs -r:System.Data.dll -r:/path/to/MySql.Data.dll

but I got the "error CS0006: cannot find metadata file
`/path/to/MySql.Data.dll' "

Please help.


View this message in context: http://mono.1490590.n4.nabble.com/Monodevelop-MySql-Connection-problem-Pls-Help-tp3803744p3803744.html
Sent from the Mono - Dev mailing list archive at Nabble.com.
Mono-devel-list mailing list
Mono-devel-list at lists.ximian.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/mono-devel-list/attachments/20110912/58a2a7f3/attachment.html 

More information about the Mono-devel-list mailing list