[Mono-dev] --------Monodevelop , MySql Connection problem ...Pls Help--------

lrt_sat satish.anasane at gmail.com
Sat Sep 10 08:33:05 EDT 2011

I am quite new to Mono and MySql , pls ignore if I sounds something silly.

I am trying to connect to MySql , just following this thread
and had following problems

>>> While installing Installing MySql.Data.dll in the GAC by executing

gacutil -i MySql.Data.dll ,

i got the message

"Failure adding assembly MySql.Data.dll to the cache: gac directories could
not be created, possibly permission issues."

Then i tried :

sudo gacutil -i MySql.Data.dll

and got the message

"Installed MySql.Data.dll into the gac (/usr/lib/mono/gac)" ,

It was looking fine , so I continued and..

>>> tried to execute the program as mentioned in the thread,

mcs TestExample.cs -r:System.Data.dll -r:/path/to/MySql.Data.dll

but I got the "error CS0006: cannot find metadata file
`/path/to/MySql.Data.dll' "

Please help.


View this message in context: http://mono.1490590.n4.nabble.com/Monodevelop-MySql-Connection-problem-Pls-Help-tp3803744p3803744.html
Sent from the Mono - Dev mailing list archive at Nabble.com.

More information about the Mono-devel-list mailing list