[Mono-dev] Enabling Support for SIMD Intrinsics

Justin Holewinski shawmishrak at gmail.com
Thu Jan 22 16:19:40 EST 2009

Is there a special configure script option to enable the SIMD intrinsic

I just compiled Mono from the 2.2 sources and compiled/executed the
following C# code snippet:

Console.WriteLine("SIMD Mode:  {0}", SimdRuntime.AccelMode.ToString());

This is printing out  "SIMD Mode:  None" regardless of the -O option to
mono.  I have tried -O=simd and -O=all.

I also tried the SIMD examples available at
http://tirania.org/blog/archive/2008/Nov-03.html (linked from Mono 2.2
Release Notes) and noticed no difference between the -O=simd and -O=-simd
comparisons, and both were significantly slower than the C version.  This
leads me to believe the code snippet above is not just lying to me.

This is on Fedora 9 x86_64 with an Intel Core i7 920 processor  (definitely
has SSE support!).  Is SIMD support only available on x86 (32-bit)?


Justin Holewinski
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/mono-devel-list/attachments/20090122/2e0e8dad/attachment.html 

More information about the Mono-devel-list mailing list