[Mono-dev] Using F# on Mono

Laurent Le Brun laurentlb at gmail.com
Thu May 15 12:40:57 EDT 2008


I'd like to use F# on Mono (on Linux). I didn't have any problem with
F#, but installation fails with the latest version of F#

During installation, I get an error on this command:

$ mono --aot bin/FSharp.Core10.dll
Mono Ahead of Time compiler - compiling assembly

** (bin/FSharp.Core10.dll:22554): WARNING **: Missing method .ctor in
assembly /home/llb/FSharp-, type

** (bin/FSharp.Core10.dll:22554): WARNING **: Can't find custom attr
constructor image: /home/llb/FSharp-
mtoken: 0x0a000002

Unhandled Exception: System.MissingMethodException: Method not found:

Does anyone have a idea how to solve this problem?

F# can be found here: http://research.microsoft.com/fsharp/release.aspx

I've tried on two different computers, with two different versions of
Mono and I get the same result.
For information:

$ mono -V
Mono JIT compiler version 1.9.1 (tarball)
Copyright (C) 2002-2007 Novell, Inc and Contributors. www.mono-project.com
        TLS:           __thread
        GC:            Included Boehm (with typed GC)
        SIGSEGV:       altstack
        Notifications: epoll
        Architecture:  amd64
        Disabled:      none



More information about the Mono-devel-list mailing list