[Mono-dev] XIM and mono-winforms-2.0

Atsushi Eno atsushi at ximian.com
Mon Aug 18 08:47:54 EDT 2008

Without precise information on what message was actually output, which
IM engine you actually used (env | grep XMODIFERS) etc., it is almost
impossible to fix something from your message. canna itself is of course not
an xim implementation.

winforms/XIM stuff is working without any problem here, and I have
never heard of any problem as of now.

Atsushi Eno

> Hi,
> What do I need to do to get XIM working with winforms? I've built
> 2.0preview1 (from the tarballs) and that seems fine. When I run a
> winform app from a terminal, I get a line "Can't find XIM" (or something
> similar) which then causes any input to get messed up (press 7 and
> that's the only thing that appears in any text box irrespective of what
> you type).
> I have canna installed and running, but still no go. Same problem.
> It's important that this gets fixed otherwise there are going to be a
> lot of winforms apps running on all platforms which are just bust.
> Paul
> ------------------------------------------------------------------------
> _______________________________________________
> Mono-devel-list mailing list
> Mono-devel-list at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-devel-list

More information about the Mono-devel-list mailing list