[Mono-dev] Cannot compile the 9/16 daily build due to: boehm-gc.c:262: parse error before `MONO_TLS_FAST'

Andy Hume andyhume32 at yahoo.co.uk
Mon Sep 17 14:19:20 EDT 2007

Assuming you're using a Windows machine normally...  Why not start by using the "Mono 1.2.5 on openSUSE 10.2" VMware Virtual Image (from <http://www.mono-project.com/Downloads>)  You can do all your initial Mono investigation and development there, and only deploy to your shared-host when you want to make you web site/application public.


	From: mono-devel-list-bounces at lists.ximian.com [mailto:mono-devel-list-bounces at lists.ximian.com] On Behalf Of mono-dev at monnet-usa.com
	Sent: 16 September 2007 23:06
	To: robertj at gmx.net; mono-devel-list at lists.ximian.com
	Subject: Re: [Mono-dev] Cannot compile the 9/16 daily build due to: boehm-gc.c:262: parse error before `MONO_TLS_FAST'
	Thanks for the quick reply. 
	I checked the version of gcc and it is really old: 2.95.4. 
	So I guess I am going to figure out how to get the newest stable version compiled and setup and take it from there for 3 & 4.
	Unfortunately since my shared host is the only place where I can do any kind of Linux development (at least for now), I am not sure how I will be able to get around the memory allocation ceiling issue.
	PS: I knew that having a shared host would bring some limitations ... but still ... :-(
	>mono-dev at monnet-usa.com wrote:
	>> First, I am newbie. I am a .net developer, but my personal web site is on a 
	>> Linux shared web host. As a result I would like to setup Mono on Apache. I 
	>> tried for the last week to compile a build without any success.
	>> I have tried the following:
	>>   1- mono-1.2.5 from ttp://go-mono.com/sources-stable/
	>>   2- SVN TAGS mono-1-2-5-p5
	>>   3- SVN TRUNK
	>>   4- and finally mono-latest (mono-20070916)
	>> For 1 & 2 I get the following error:
	>>             GLib-ERROR **: gmem.c:135:g_malloc(): failed to allocate 8192 
	>>             aborting...
	>>             Stacktrace:
	>Your system ran out of memory.
	>You may try to reconfigure with --disable-mcs-build and copy all
	>managed components (assemblies, compiler) from another machine
	>running the *same* mono version.
	>Anyway, I doubt that you can run ASP.NET on such a crippled
	>> For 3 and 4, I get a different error:
	>> boehm-gc.c: At top level:
	>> boehm-gc.c:262: parse error before `MONO_TLS_FAST'
	>> boehm-gc.c:262: syntax error before `void'
	>> In file included from ../../mono/metadata/domain-internals.h:11,
	>>                  from metadata-internals.h:8,
	>>                  from boehm-gc.c:263:
	>This seems to be a gcc problem. Which gcc version is this?
	>Mono-devel-list mailing list
	>Mono-devel-list at lists.ximian.com

More information about the Mono-devel-list mailing list