[Mono-dev] Moma 1.2.6 bug

Dennis Hayes denisraytek at yahoo.com
Fri Dec 14 01:17:23 EST 2007

I downloaded the Moma 1.2.6 definitions, but when I try to run Moma withthe new definitions I get an execption
  length cannot be less than zero
  Parameter name: length.
  I tried this on SharpDevelop.exe (version 2.1) and several other assemblies, all gave the same error.
  Swtiching to the 1.2.4 definitions ran fine.
  Is this my mistake?
  Is it a known bug?
  Shall I file a bug report?
  Send more info?
  BTW My system is Win XP, with .Net 1.1, 2.0, (2.1? I have silverlight), 3.0, 3.5, and probably Mono.
  the top of the stack track is
  System.ArgumentOutOfRangeException: Length cannot be less than zero.
Parameter name: length
   at System.String.InternalSubStringWithChecks(Int32 startIndex, Int32 length, Boolean fAlwaysCopy)
   at MoMA.Analyzer.Method.ParseMethod()
   at MoMA.Analyzer.BaseChecker..ctor(Stream input)
   at MoMA.Analyzer.AssemblyAnalyzer.LoadDefinitions(Stream monoTodoDefinitions, Stream notImplementedDefinitions, Stream missingDefinitions)


Never miss a thing.   Make Yahoo your homepage.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/mono-devel-list/attachments/20071213/215fd0cf/attachment.html 

More information about the Mono-devel-list mailing list