[Fwd: Re: [Mono-dev] Mono Windows Installer Released]

Wade Berrier wberrier at novell.com
Mon Oct 3 16:05:12 EDT 2005

Here's another error which makes me think something is wrong besides my
environment or the libraries I have.

*** Warning: linker path does not have real file for library -lole32.
*** I have the capability to make that library automatically link in
*** you link to this library.  But I can only do this if you have a
*** shared version of the library, which you do not appear to have
*** because I did check the linker path looking for a file starting
*** with libole32 and none of the candidates passed a file format test
*** using a file magic. Last file checked: /lib/w32api/libole32.a
*** The inter-library dependencies that have been dropped here will be
*** automatically added whenever a program is linked with this library
*** or is declared to -dlopen it.

That's a file provided by cygwin in the w32api package.  I'm trying to
keep my cygwin installation to a minimum:




And of course other packages get selected by dependency.

Am I missing something obvious?


On Mon, 2005-10-03 at 13:19 -0600, Wade Berrier wrote:
> Hey,
> On Sat, 2005-10-01 at 02:23 +0200, Zoltan Varga wrote:
> > This works fine on my system using latest cygwin. My libint is in
> > /lib/libintl.a. Perhaps you don't have that package installed, or
> > libintl-1.dll is in a directory
> > in your PATH so libtool finds it first ?
> This same error happens with a lot of deps when I link (gmodule-2.0,
> gthread-2.0, glib-2.0, intl, iconv, ws2_32, psapi, 
> ole32).
> I do have libintl-1.dll in my path.  What should my environment be?
> Are you using the cygwin glib deps?  I'm using the following glib deps:
> ftp://ftp.gtk.org/pub/gtk/v2.6/win32/glib-2.6.6.zip
> ftp://ftp.gtk.org/pub/gtk/v2.6/win32/glib-dev-2.6.6.zip
> http://www.gimp.org/~tml/gimp/win32/pkgconfig-0.15.zip
> http://www.gimp.org/~tml/gimp/win32/libiconv-1.9.1.bin.woe32.zip
> http://www.gimp.org/~tml/gimp/win32/gettext-0.14.5.zip
> I'm using these so that I can build with them and also package them up
> for the installer.
> I guess the only other place I know about that I could get the deps is
> from gladewin32.  He doesn't offer zip files (which is easier to
> automate with) but if I had to, I could create a zip file from what his
> installer lays down.
> I don't think that using the gladewin32 fixes the problem though.  I
> still get the same errors when I build against the mono
> installer, and came with the gladewin32 files.
> Ideas?
> Wade

More information about the Mono-devel-list mailing list