[Mono-devel-list] monodevelop-0.7

Cory Trese cory.trese at gmail.com
Sun May 22 20:04:21 EDT 2005


You should see at the bottom of your "gtk-sharp" configuration a
listing of all the libraries built, as below.  This list depends on
what GTK/Gnome libraries you  have installed for the package to
generate bindings to.

Configuration summary

    * Installation prefix = /usr/local
    * C# compiler: /usr/local/bin/mcs -define:GTK_SHARP_2_6

Optional assemblies included in the build:

    * art-sharp.dll: yes
    * gnomevfs-sharp.dll: yes
    * gnome-sharp.dll: yes
    * glade-sharp.dll: yes
    * gda-sharp.dll: yes
    * gnomedb-sharp.dll: yes
    * rsvg-sharp.dll: yes
    * gtkhtml-sharp.dll: yes
    * vte-sharp.dll: yes
    * gtk-dotnet.dll: yes

You, in particular, should check for the "gnome-sharp.dll" library. 
If it is present and the MD environment still reports the same error,
check your installation prefix (/usr/local for me) and compare it to

You may also need to run 'ldconfig'.

I can, however, assure you that it does work out of SVN.  I have been
doing it every few days for about a week now.  The error your reported
is one that I early in my attempts as well.

- Cory Trese

On 5/22/05, Michael Rasmussen <mir at miras.org> wrote:
> Hi all,
> Anybody been able to run monodevelop-0.7 under mono-1.1.7?
> I have fetch all mono-1.1.7 from source, build and installed it. This
> works.
> I have fetch all packages from monodevelop an build and deploy in the
> recommended order but it still does not work. It installs and deploys
> without any errors.
> When starting monodevelop I get this error message:
> loke:/tmp/monodevelop-0.7/build/bin$ mono MonoDevelop.exe
> Unhandled Exception: System.DllNotFoundException: gnomesharpglue-2
> in (wrapper managed-to-native) Gnome.Program:gtksharp_gnome_program_init
> (string,string,Gnome.ModuleInfo&,int,string[],int,Gnome.Program/PropertyArg[])
> in <0x00284> Gnome.Program:.ctor (System.String app_id, System.String
> app_version, ModuleInfo module, System.String[] argv, System.Object[]
> props)
> in <0x004c1> MonoDevelop.SharpDevelopMain:Main (System.String[] args)
> I have even tried gtk#-1.0.6 instead of gtk#-1.9.5 but I get the same
> error.
> OS: Debian Sid (2.6.11-1-686)
> loke:/tmp/monodevelop-0.7/build/bin$ mono --version
> Mono JIT compiler version 1.1.7, (C) 2002-2005 Novell, Inc and
> Contributors. www.mono-project.com
>         TLS:           __thread
>         GC:            Included Boehm (with typed GC)
>         SIGSEGV      : normal
>         Globalization: normal
> Hilsen/Regards
> Michael Rasmussen
> Get my public GnuPG keys:
> michael  rasmussen  cc
> http://keyserver.veridis.com:11371/pks/lookup?op=get&search=0xD3C9A00E
> mir  datanom  net
> http://keyserver.veridis.com:11371/pks/lookup?op=get&search=0xE501F51C
> mir  miras  org
> http://keyserver.veridis.com:11371/pks/lookup?op=get&search=0xE3E80917
> --------------------------------------------------------------
> Q: What do you call a half-dozen Indians with Asian flu?
> A: Six sick Sikhs (sic).
> BodyID:12878188.2.n.logpart (stored separately)
> _______________________________________________
> Mono-devel-list mailing list
> Mono-devel-list at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-devel-list

More information about the Mono-devel-list mailing list