[Mono-devel-list] problem with DB2Command class

Pablo Cardona pcardona37 at gmail.com
Wed Jul 6 05:07:59 EDT 2005

Hi, I'm trying to make queries with a DB2 database, and when I try to
execute a query with DB2Command class I always have the same

Unhandled Exception: IBM.Data.DB2.DB2Exception: ERROR [08003] 
InternalExecuteNonQuery: Unable to allocate statement handle.
in <0x000d3> IBM.Data.DB2.DB2Command:AllocateStatement (System.String location)
in (wrapper remoting-invoke-with-check)
IBM.Data.DB2.DB2Command:AllocateStatement (string)
in <0x001d8> IBM.Data.DB2.DB2Command:ExecuteNonQueryInternal
(CommandBehavior behavior)
in (wrapper remoting-invoke-with-check)
in <0x0003f> IBM.Data.DB2.DB2Command:ExecuteReader (CommandBehavior behavior)
in (wrapper remoting-invoke-with-check)
IBM.Data.DB2.DB2Command:ExecuteReader (System.Data.CommandBehavior)
in <0x0000f> IBM.Data.DB2.DB2Command:ExecuteReader ()
in (wrapper remoting-invoke-with-check)
IBM.Data.DB2.DB2Command:ExecuteReader ()in <0x000ed> MainClass:Main
(System.String[] args)

I've tried the methods ExecuteReader and the method Fill of
DB2DataAdapter, also tried to insert data in the database with the
ExecuteNonQuery method, but I always have that exception with the same
error message.

I can open and close the connection and there is no errors with the
open and close method.
The SQL commands are correct because they works in the DB2 commands console. 
I have installed DB2 in linux and windows, and I've executed the code
in both S.O. with local an remote DB, and It can connects to the DB
but with those methods of the DB2Command class that exception is
always thrown.

Can this be a problem with Mono or the DB2 client?
There's any problem with those methods of the DB2Command class?

Thanks for the help.

More information about the Mono-devel-list mailing list