[Mono-devel-list] Beta1 preview.

Duncan Mak duncan at ximian.com
Tue May 4 03:26:42 EDT 2004


On Mon, 2004-05-03 at 20:42, Miguel de Icaza wrote:
>     Please give it a shot at these source packages:
> 	http://primates.ximian.com/~miguel/beta1
>     Duncan is building packages for a few distributions now.

Get them while they are hot:


I made mono, gtk-sharp and (monodoc) packages. I know the gtk-sharp
packages are kinda broken, there is a circular dependency between
gtk-sharp and monodoc now. I'll try to fix that tomorrow.

I can't really build monodoc, I get this error:

        mcs -debug -out:monodoc.dll -target:library
        /resource:./ecmaspec-html.xsl,ecmaspec-html.xsl ./colorizer.cs
        ./man-provider.cs ./monohb-provider.cs ./xhtml-provider.cs
        ./ecma-provider.cs ./simple-provider.cs ./html-helper.cs
        ./provider.cs ./index.cs ./error-provider.cs
        ./ecmaspec-provider.cs ./editing.cs ./settings.cs
        ./commentservice.cs ./XmlNodeWriter.cs ./AssemblyInfo.cs
        -r:ICSharpCode.SharpZipLib -r:System.Web -r:System.Web.Services
        error CS0006: Cannot find assembly `ICSharpCode.SharpZipLib'
        Compilation failed: 1 error(s), 0 warnings
        gmake[1]: *** [monodoc.dll] Error 1
        gmake[1]: Leaving directory

Initially, it was erroring on "ICSharpCode.SharpZipLib.dll", which I
tried to fix by patching the Makefile.am and Makefile.in to remove the
dll suffix. It didn't work, we still get the error above.

It did build on redhat-9-i386, and I uploaded it. It's a cheat though.
That particular setup has assemblies in $prefix/lib.

Bonne nuit,


More information about the Mono-devel-list mailing list