[Mono-devel-list] Problem with System.Diagnostics.Process?

Borja Sánchez Zamorano borsanza at terra.es
Wed Mar 24 15:32:47 EST 2004


  It's a bug, try with (psi.UseShellExecute = false;). Example:

ProcessStartInfo psi = new ProcessStartInfo ("mcs", "-t:library
psi.UseShellExecute = false;
System.Diagnostics.Process p;
p = System.Diagnostics.Process.Start(psi);


El mié, 24-03-2004 a las 19:08, jat850 at mail.usask.ca escribió:
> Hi folks,
> I just upgraded from mono 0.30.99 to 0.31.00 today.  After doing so, I noticed
> something broken with a particular mono app a friend had written and that I have
> used all along to assist in my mono compiles.
> After playing around with it a bit, I noticed the problem came down to creating
> and starting a process:
> *snip*
> System.Diagnostics.Process p;
> p = System.Diagnostics.Process.Start("mcs", "-t:library test.cs");
> *snip*
> In mono 0.30.99, this worked no problem.
> In mono 0.31.00, I get an error back from mcs indicating that no source files
> are specified, i.e. it's not receiving the command line parameters properly.  I
> also tried Start("cat", "test.cs") to the same result - cat just sits there
> waiting for input.
> The same code compiles and runs fine under Windows using csc/.NET 1.1 SDK.
> For some reason, between 0.30.99 and 0.31.00, it stopped working.  Now here's a
> tricky addendum: when I run the same code as ROOT, it works fine.  When I run as
> a non-priv user, it fails.
> I have tried specifying absolute paths to the files in the arguments in
> question, but that doesn't seem to help.  It's almost as though it's forgotten
> about the command line parameters entirely.
> Can anyone identify what I may be overlooking here?
> Thanks,
> Jeremy
> _______________________________________________
> Mono-devel-list mailing list
> Mono-devel-list at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-devel-list
Borja Sánchez Zamorano <borsanza at terra.es>

More information about the Mono-devel-list mailing list