[Mono-devel-list] Problem with System.Diagnostics.Process?

jat850 at mail.usask.ca jat850 at mail.usask.ca
Wed Mar 24 13:08:21 EST 2004

Hi folks,

I just upgraded from mono 0.30.99 to 0.31.00 today.  After doing so, I noticed
something broken with a particular mono app a friend had written and that I have
used all along to assist in my mono compiles.

After playing around with it a bit, I noticed the problem came down to creating
and starting a process:

System.Diagnostics.Process p;
p = System.Diagnostics.Process.Start("mcs", "-t:library test.cs");

In mono 0.30.99, this worked no problem.

In mono 0.31.00, I get an error back from mcs indicating that no source files
are specified, i.e. it's not receiving the command line parameters properly.  I
also tried Start("cat", "test.cs") to the same result - cat just sits there
waiting for input.

The same code compiles and runs fine under Windows using csc/.NET 1.1 SDK.

For some reason, between 0.30.99 and 0.31.00, it stopped working.  Now here's a
tricky addendum: when I run the same code as ROOT, it works fine.  When I run as
a non-priv user, it fails.

I have tried specifying absolute paths to the files in the arguments in
question, but that doesn't seem to help.  It's almost as though it's forgotten
about the command line parameters entirely.

Can anyone identify what I may be overlooking here?


More information about the Mono-devel-list mailing list