[Mono-devel-list] Fresh install on Debian

Les Ferguson lhf at xtra.co.nz
Sat Nov 29 22:17:00 EST 2003

Hi all,   I got all the source files for 0.28 & tried to install Mono (Debian 
support seems to have been dropped after 0.26).  Now I have tried to follow 
all the instructions but I can only get Mono to build & install properly, the 
mcs stuff falls over ...

make[2]: Leaving directory `/usr/local/share/mono_src/mcs-0.28/tools/mono-xsd'
make[2]: Entering directory `/usr/local/share/mono_src/mcs-0.28/tools/
MONO_PATH="../../class/lib:$MONO_PATH" mono  ../../mcs/mcs.exe /r:../../class/
lib/Mono.Security.dll  -d:NET_1_1 -g cert2spc.cs AssemblyInfo.cs
mono: relocation error: /usr/local/lib/libmono.so.0: undefined symbol: 
make[2]: *** [cert2spc.exe] Error 127
make[2]: Leaving directory `/usr/local/share/mono_src/mcs-0.28/tools/security'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/local/share/mono_src/mcs-0.28/tools'
make: *** [all-recursive] Error 1

I cannot determine exactly what the process is for a fresh install from 
tarballs, the instructs I have found make circular references to CVS 
procedures, but I didn't want to use CVS.  Are the tarballs usable for a 
fresh new installation ?

Les F

More information about the Mono-devel-list mailing list