[Mono-bugs] [Bug 570728] VS returns UIAutomationWinforms exception FileNotFound attempting remote debug

bugzilla_noreply at novell.com bugzilla_noreply at novell.com
Fri Jan 15 11:14:19 EST 2010



--- Comment #7 from Brian Kesecker <bkesecker at augustasystems.com> 2010-01-15 16:14:17 UTC ---
Aye aye aye...  Yesterday this was working for me, today it started out that
way, but here is what I did to make this problem reoccur:

I have two separate projects in VS that ultimately become the project that gets
remotely debugged on the VM.  Project A is just a DLL that doesn't use
winforms.  Project B obviously must use winforms.  I made code changes to A,
but didn't compile it (only saved).  When debugging like this, all breakpoints
will say they can't be hit in Project B if the breakpoint is in the code for
Project A (because the DLL referenced by Project B does not match the physical
code in Project A).

At this point, remotely debugging Project B works fine.

I turned break on all exception on.  An error generated while remotely
debugging Project B occurred in the code owned by Project A, but because the
physical code did not match the DLL, no call stack could be generated, nor was
the location where the exception occurred breakable.  I then got a box that
looked just like the UIAutomationWinforms, except the exception listed was the
one I expected to see (NullReferenceException, forgot to get screenshot).

Next, I selected "Stop Debugging" from the Debug menu.  The next time I tried
to Remotely Debug, I got the same error message in the first image attachment.

Like before, I thought resetting things might help.  So, I restarted the
Mono-GUI-Server on the VM, closed down my VS instances, recompiled my Project A
(so that the physical code matched the DLL) and tried again.  Still got the
same UIAutomationWinforms error message.

I've attached another screenshot of a strange error message (which occurred
when I tried to Remotely Debug), but I'm sure, like the previous screenshot, it
won't be useful.

I'm going to try to reboot everything again.  I hope I have better results, but
constantly having to reset everything due to this error obviously isn't

Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.

More information about the mono-bugs mailing list