[Mono-bugs] [Bug 476354] .NET exe / binary doesn't work with Mono (System.TypeInitializationException)

bugzilla_noreply at novell.com bugzilla_noreply at novell.com
Mon Jan 4 15:50:12 EST 2010



--- Comment #6 from Thomas Goldstein <stifu at free.fr> 2010-01-04 20:50:10 UTC ---
I tried again with openSUSE 11.2 and Mono 2.6.1. I don't get a
System.TypeInitializationException anymore.

If I right click the exe and do run with Mono, I get an exception that makes
the app silently exit. The exception is: System.ArgumentException: A null
reference or invalid value was found [GDI+ status: InvalidParameter]

However, if I try to run the exe through the console ("mono
WindowsApplication.exe"), then it works. I think this may have something to do
with the image path, like the relative path varies depending on how I launch
the exe. As in, running it by right clicking the exe sets a wrong relative
If that's the case, then it's not that the .NET exe doesn't work with Mono,
just that I tried to run the exe in a different way, which doesn't work right.

Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
You are the assignee for the bug.

More information about the mono-bugs mailing list