[Mono-bugs] [Bug 326011] Creating two connections to the same SQL database throws an exception

bugzilla_noreply at novell.com bugzilla_noreply at novell.com
Thu Jul 10 08:28:22 EDT 2008


User paul at digitaltinder.com added comment

Paul Sainsbury <paul at digitaltinder.com> changed:

           What    |Removed                                         |Added
             Status|NEEDINFO                                        |NEW
      Info Provider|paul at digitaltinder.com                          |

--- Comment #7 from Paul Sainsbury <paul at digitaltinder.com>  2008-07-10 06:28:21 MDT ---

Firstly, I need to say that since I first logged the bug I've moved onto
Windows Vista.  (I'm trying to find the time to downgrade to XP, but haven't
had a chance yet)

I have installed Mono 1.9.1 and the code still breaks when connecting to my
local database but works fine when connecting to one that is a default instance
on a remote pc.  

If I run "CodeThatBreaks" I get the following error twice (once for each
attempt at creating a new connection to the database:
Connection reset by peer
  at System.Net.Sockets.Socket.ReceiveFrom_nochecks (System.Byte[] buf, Int32
offset, Int32 size, SocketFlags flags, 
System.Net.EndPoint& remote_end) [0x00000] 
  at System.Net.Sockets.Socket.ReceiveFrom (System.Byte[] buf,
System.Net.EndPoint& remote_end) [0x00000] 
  at System.Net.Sockets.UdpClient.Receive (System.Net.IPEndPoint& remoteEP)
  at System.Data.SqlClient.SqlConnection+SqlMonitorSocket.DiscoverTcpPort ()
  at System.Data.SqlClient.SqlConnection.DiscoverTcpPortViaSqlMonitor
(System.String ServerName, System.String 
InstanceName) [0x00000] 
  at System.Data.SqlClient.SqlConnection.ParseDataSource (System.String
theDataSource, System.Int32& thePort, 
System.String& theServerName) [0x00000] 
  at System.Data.SqlClient.SqlConnection.Open () [0x00000] 
  at LibraryWin.Form1.CodeThatWorks () [0x00000] 

If I run "CodeThatWorks", I get the error above for the first connection
attempt, and the error below for the second attempt at using the connection:
SQL Server does not exist or access denied.
  at System.Data.SqlClient.SqlConnection.Open () [0x00000] 
  at System.Data.Common.DbDataAdapter.Fill (System.Data.DataSet dataSet, Int32
startRecord, Int32 maxRecords, 
System.String srcTable, IDbCommand command, CommandBehavior behavior) [0x00000] 
  at System.Data.Common.DbDataAdapter.Fill (System.Data.DataSet dataSet)
  at LibraryWin.Form1.CodeThatWorks () [0x00000] 

I've run this with my firewall disabled, and with it enabled.  I am running the
app by going to the "Mono-1.9.1 Command Prompt", then changing to the folder
where the application's .exe is located and then typing "mono LibraryWin.exe"
(without the quotes).

If I run the .exe directly (i.e. so that it uses MS .Net), it runs

I'm quite happy to send you a copy of the exe, or to organise remote access to
my PC, in case there's something specific about my setup that you can't
reproduce?  I can try testing on a Windows XP machine too, if that would help.


Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
You are the assignee for the bug.

More information about the mono-bugs mailing list