[Mono-bugs] [Bug 384236] New: System.Web.Service call WebMethod not working

bugzilla_noreply at novell.com bugzilla_noreply at novell.com
Mon Apr 28 01:57:12 EDT 2008


           Summary: System.Web.Service call WebMethod not working
           Product: Mono: Runtime
           Version: 1.2.6
          Platform: Other
        OS/Version: Other
            Status: NEW
          Severity: Blocker
          Priority: P5 - None
         Component: remoting
        AssignedTo: lluis at novell.com
        ReportedBy: csvadiraj at novell.com
         QAContact: mono-bugs at lists.ximian.com
          Found By: ---

zmd uses WebMethod attribute for exposing certain WebMethod calls for remoting.

This is used by ZLM server for push call semantic for certain functionality.

WebMethod calls are never triggered with mono Version 1.2.6

However tried downgrading the mono version to 1.2.2 and 1.2.5 without changing
methods in the zmd code base. Functionality works fine.

Tried on mono-1.9.1 (beta) WOnt work
Tried on mono-1.2.6 wont work.

This is blocking our release. ZMD is tied with version 1.2.6 for xlmRPC
interface which was broken in 1.2.5.

Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.

More information about the mono-bugs mailing list