[Mono-bugs] [Bug 319973] TLS support in Novell.Directory. Ldap fails with unhandled exception

bugzilla_noreply at novell.com bugzilla_noreply at novell.com
Wed Sep 26 08:49:23 EDT 2007


--- Comment #2 from Loren Bandiera <lorenb at mmgsecurity.com>  2007-09-26 06:49:23 MST ---
I re-ran the test case and I still get the exact same error with Mono

$ ./test.exe 389 "" ""
Connecting to:
System.ArgumentNullException: null key
Parameter name: key
  at System.Collections.Hashtable.Find (System.Object key) [0x00000] 
  at System.Collections.Hashtable.Contains (System.Object key) [0x00000] 
  at System.Collections.Hashtable.ContainsKey (System.Object key) [0x00000] 
  at Novell.Directory.Ldap.Utilclass.RespExtensionSet.findResponseExtension
(System.String searchOID) [0x00000] 
(Novell.Directory.Ldap.Rfc2251.RfcLdapMessage inResponse) [0x00000] 
  at Novell.Directory.Ldap.LdapMessageQueue.getResponse (.Integer32 msgid)
  at Novell.Directory.Ldap.LdapMessageQueue.getResponse () [0x00000] 
  at Novell.Directory.Ldap.LdapConnection.startTLS () [0x00000] 
  at StartTLSTest.Main (System.String[] args) [0x00000]

$ mono --version
Mono JIT compiler version (tarball)
Copyright (C) 2002-2007 Novell, Inc and Contributors. www.mono-project.com
        TLS:           __thread
        GC:            Included Boehm (with typed GC)
        SIGSEGV:       normal
        Architecture:  amd64
        Disabled:      none

Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.

More information about the mono-bugs mailing list