[Mono-bugs] [Bug 71588][Wis] Changed - Async Socket BeginRead not functioning properly

bugzilla-daemon@bugzilla.ximian.com bugzilla-daemon@bugzilla.ximian.com
Fri, 21 Jan 2005 16:38:55 -0500 (EST)

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by gonzalo@ximian.com.


--- shadow/71588	2005-01-21 16:26:58.000000000 -0500
+++ shadow/71588.tmp.3685	2005-01-21 16:38:55.000000000 -0500
@@ -1,13 +1,13 @@
 Bug#: 71588
 Product: Mono: Class Libraries
 Version: 1.1
 OS: unknown
 OS Details: OSX 10.3.7
-Status: NEW   
+Status: RESOLVED   
+Resolution: WONTFIX
 Severity: Unknown
 Priority: Wishlist
 Component: CORLIB
 AssignedTo: gonzalo@ximian.com                            
 ReportedBy: grompf@sublimeintervention.com               
 QAContact: mono-bugs@ximian.com
@@ -65,6 +65,12 @@
 Ok;  this was a stupid coding bug by me; Server.cs line 64 should have been a 
 socket_event.Reset () not a socket_event.Set () (It was looping on beginaccept forever, 
 filling the threadpool).  However there is still a bug here as the code worked on MS.NET
+------- Additional Comments From gonzalo@ximian.com  2005-01-21 16:38 -------
+The code worked on .NET because of the different threadpool-IO ports
+implementation. It filled out the threadpool for us...
+One of these days I'll rewrite that.