[Mono-bugs] [Bug 71589][Maj] New - French keyboard layout: bad behaviour for " and ^

bugzilla-daemon@bugzilla.ximian.com bugzilla-daemon@bugzilla.ximian.com
Fri, 21 Jan 2005 16:30:15 -0500 (EST)


Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by benjamin.dasnois@gmail.com.

http://bugzilla.ximian.com/show_bug.cgi?id=71589

--- shadow/71589	2005-01-21 16:30:15.000000000 -0500
+++ shadow/71589.tmp.2906	2005-01-21 16:30:15.000000000 -0500
@@ -0,0 +1,29 @@
+Bug#: 71589
+Product: Mono: Class Libraries
+Version: unspecified
+OS: 
+OS Details: RH FC3
+Status: NEW   
+Resolution: 
+Severity: 
+Priority: Major
+Component: Windows.Forms
+AssignedTo: jackson@ximian.com                            
+ReportedBy: benjamin.dasnois@gmail.com               
+QAContact: mono-bugs@ximian.com
+TargetMilestone: ---
+URL: 
+Cc: 
+Summary: French keyboard layout: bad behaviour for " and ^
+
+Hi,
+actually pressing " doesn't do anything and pressing ^ writes a ^ directly,
+this is a bad behaviour, the keys should behave in this way:
+first you hit ", nothing appears to have changed, then you press some
+caracter which can have a " on their top (like ,,,,,) and then the
+corresponding caracter appears :) If the key combination is invalid (the
+caracter entered after " can not have a ", then nothing happens (and you
+can type any letter now, as if " hasn't been pressed). ^ should behave the
+same way. I also noticed that  isn't handled (this is a AltGr caracter) !
+still doesn't want to show too and  is replaced by %,  doesn't appear,
+too and  too.