[Gtk-sharp-list] Installing gtk# 0.14, missing liblinc.la when linking

Leo Spalteholz leo@thewoodpecker.ca
Mon, 24 Nov 2003 12:05:10 -0800

On November 23, 2003 10:55 pm, Sebastian wrote:
> Hello,
> I use Debian/sid with mono 0.26, and a manually installed gtk-sharp
> 0.12. Now I want to update to 0.14 and run the configure script, which
> results in:

<snip />

> -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0 grep: /usr/lib/liblinc.la:
> No such file or directory
> sed: can't read /usr/lib/liblinc.la: No such file or directory
> libtool: link: `/usr/lib/liblinc.la' is not a valid libtool archive
> make[1]: *** [libgtksharpglue.la] Error 1
> make[1]: Leaving directory `/tmp/gtk-sharp-0.14/glue'
> make: *** [native] Error 1

Hmm.. Same problem here.  I'll try to install liblinc-dev from source and 
let you know how it goes.

Btw, semi-unrelated but have you (or anyone) gotten mono to compile from 
cvs on debian?  I have the 0.26 from debianplanet but I'd like to install 
the newer one so I can run monodoc.  It always complains about mscorlib 
being out of date.  I've used the monocharge (lite) with no success.  
Always the same error on make and I've tried everything I can think of.  
Maybe alien will work on the rpms... :P