[MonoDevelop] Stupid Noob Question: MonoDevelop VB .net

Lewis Balentine lewis at keywild.com
Tue May 16 07:49:29 UTC 2017

It does not appear that the mail list has much activity but on the off 
chance that someone in the developer group does on occasion check the 
list .......

I have tried all Linux versions of Monodevelop that I could find. 
Despite any claims to the contrary VB.NET does NOT work in any of them. 
I tried the Flatpak 'preview' distribution and that proved to be the 
worst of the lot. In my opinion Flatpak should be considered a 
non-starter. My current installation is:
MonoDevelop: Version 5.10
Installation UUID: 52518412-b276-4425-8171-bda7cb775914
     Mono 5.0.0 (Stable Thu May 11 14:33:04 UTC 2017) 
     GTK+ 2.24.30 (Mint-X-Grey theme)

Build Information: Build information unavailable

Operating System
Linux Mint 18.1, Mate Desktop, Linux 4.4.0-77-generic #98-Ubuntu SMP Wed 
Apr 26 08:34:02 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Hardware: HP8460W, 20GB
MonoDevelop does work with C# in console mode or the GTK Gui.
Perhaps Monodevelop VB.NET works on Mac or Windows but I find it hard to 
believe anyone has the nerve to claim it works on Linux. I strongly 
suspect it is one of those situations where no one gives flying f###.

On 05/14/2017 01:00 PM, Lewis Balentine wrote:
> I have Linux Mint Mate 18.2. One of the things I like about Linux Mint 
> is that using the package manager most applications have been test and 
> work more or less as advertised .... Monodevelop (version 5.10) not so 
> much. It does install but when I try to use VB to create "Hello Word" 
> everything goes awry.
> Problem one:
> Error while trying to load the project 
> '/home/lewis/MonoProjects/HellowWordlVB/HellowWordlVB/HellowWordlVB.vbproj': 
> Project does not support framework '.NETFramework,Version=v4.5'
> So searching around a bit I found that I needed to edit line 10 of the 
> file 
> '/home/lewis/MonoProjects/HellowWordlVB/HellowWordlVB/HellowWordlVB.vbproj' 
> to the Framework Version reference from 4.5 to 4.0
> Then restart Monodelevop and reload the project
> Joy, Joy, Joy ..... well not so much
> Problem two: .Net 4.0 not installed
> lewis at HP8460W ~ $ mono --version
> Mono JIT compiler version 4.2.1 (Debian
> Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. 
> www.mono-project.com
>     TLS:           __thread
>     SIGSEGV:       altstack
>     Notifications: epoll
>     Architecture:  amd64
>     Disabled:      none
>     Misc:          softdebug
>     LLVM:          supported, not enabled.
>     GC:            sgen
> Changing the reference to "4.2.1" also gave a similar error.
> Despite hours of searching I have NOT found any fix/patch/solution to 
> this problem although I did find a number questions about it.
> ======================
> Does anyone have Monodevelop VB operating as expected ?
> Is there any Linux Distribution that Monodevelop VB  does run on as 
> expected ?
> To be fair: Monodevelop C# does compile, debug and run "Hello World" 
> as expected.
> Back in the day I wrote a lot of VB6 code on Windows XP. I even wrote 
> a couple of programs in VB .Net on Windows 7. Until VB works as 
> expected, I have rate monodevelop as "not ready for prime time".   I 
> am an old man but I have high hopes of seeing this change before I die.
> Respectfully,
> Lewis Balentine
> Houston, Texas
> _______________________________________________
> Monodevelop-list mailing list
> Monodevelop-list at lists.dot.net
> http://lists.dot.net/mailman/listinfo/monodevelop-list

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.dot.net/pipermail/monodevelop-list/attachments/20170516/bf85b2d7/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: image/png
Size: 17794 bytes
Desc: not available
URL: <http://lists.dot.net/pipermail/monodevelop-list/attachments/20170516/bf85b2d7/attachment-0001.png>

More information about the Monodevelop-list mailing list