[MonoDevelop] unmanaged DLL issues

Jeffrey Stedfast jeff at xamarin.com
Fri Mar 28 12:53:16 UTC 2014

Hi Shadoh,

The problem is that native win32 dlls are not supported in Linux.

Sent from my iPhone

> On Mar 25, 2014, at 4:13 AM, shadoh <shadowdust123 at gmail.com> wrote:
> Hey guys, 
> I'm having problems with Monodevelop, I'm using sharpallegro as a
> wrapper for allegro in a test project I'm doing, and it is throwing a
> DllNotFoundException on alleg44.dll, even though it is set to copy to the
> output directory (and it is definitely there). If I run the executable
> generated in the output folder, it finds the DLL and the program executes
> perfectly fine.
> What's going on? Anyway to fix this, I've tried placing the DLL in the /lib
> and /usr/lib folder, but that didn't work so have since removed them from
> there.
> I've also checked the permissions, and they're all permissive.
> I'm running Ubuntu Saucy.
> Thanks in advance!
> --
> View this message in context: http://mono.1490590.n4.nabble.com/unmanaged-DLL-issues-tp4662356.html
> Sent from the Mono - MonoDevelop IDE mailing list archive at Nabble.com.
> _______________________________________________
> Monodevelop-list mailing list
> Monodevelop-list at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/monodevelop-list

More information about the Monodevelop-list mailing list