[MonoDevelop] Trouble building monodevelop on SuSE Linux Enterprise Server 11

thomas42 thomas.heidelberg at on-this-planet.eu
Tue Mar 4 12:13:52 UTC 2014


I want to compile the recent monodevelop source package on a SuSE Linux
Enterprise Server 11, but have kind of trouble to get my hands on libglade
resp glade-sharp. I found  this post
which seems to be mainly the same problem (i do get the same error
messages), but do have no idea how to get the libglade2-dev mentioned in the
answer to that question into my system. 

When I check the software installed (using YAST) I see that two glade
packages (libglade2 version 2.6.4.-1.2.267 and libglade2-32 same version)
are installed. glade-sharp2 is also available, but I cannot install it using
Yast without breaking some of its depencies (actually libglade-2_0-0 is the
dependency which is reported to be missing.) 

I tried to get libglade as a source package, but could not find a package
which convinced me to prove more helpful than what is already installed. 

I considered using the precompiled monodevelop binary for openSuSE, but I'm
hesitating since I do have the mono framework installed from Yast2
and have no idea whether that will conflict. 

(In the end I want to use monodevelop to build on mono 3.2.8 which I have
installed locally and parallel to the SuSE installation following the
instructions I got from  here
<http://www.mono-project.com/Parallel_Mono_Environments>   (and which seems
to work fine))

Any suggestions on how I should proceed?



View this message in context: http://mono.1490590.n4.nabble.com/Trouble-building-monodevelop-on-SuSE-Linux-Enterprise-Server-11-tp4662111.html
Sent from the Mono - MonoDevelop IDE mailing list archive at Nabble.com.

More information about the Monodevelop-list mailing list