[MonoDevelop] Failing to compile on Linux in last few days - %(Culture)

Timotheus Pokorra timotheus.pokorra at solidcharity.com
Thu Aug 28 04:50:58 UTC 2014

Hello Jesse,

(cross posting to Mono Development list because it seems to be a
problem in Mono git master)

I checked the specific revision of Mono that still worked to build MonoDevelop:

My next build of Mono was based on
and that caused this error when building MonoDevelop.

I cannot see myself which commit might be causing the new behaviour.

Here again the error for the mono list:

 /opt/mono/lib/mono/4.5/Microsoft.Common.targets: error : Cannot copy
to /root/rpmbuild/BUILD/monodevelop-5.4/build/AddIns/DisplayBindings/Gettext/MonoDevelop.Gettext.resources.dll,
as the source file doesn't exist.

With Mono 3.6, the copy command looks like this and works fine:

Copying file from
to '/root/rpmbuild/BUILD/monodevelop-5.4/build/AddIns/DisplayBindings/Gettext/am/MonoDevelop.Gettext.resources.dll'

Does anybody know what causes this?


On 28 August 2014 02:55, Jesse Litton <monodevelop-list at eternaldusk.com> wrote:
> Ah, that fits - because I too generally build with the latest mono from
> git master branch.
> -Jesse
> On 08/27/2014 03:50 PM, Timotheus Pokorra wrote:
>> Hello Jesse,
>> I noticed the same error as well.
>> I think it was no change in monodevelop, but a change in the latest
>> mono built from git master.
>> It still worked fine with Mono git master from Friday morning, but
>> failed a day later.
>> I can compile Monodevelop git master fine with mono 3.6.
>> Timotheus

More information about the Monodevelop-list mailing list